Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN









1993 Ford F150 "Knock Sensor"


  Email This Post



Coolkat
New User

Mar 2, 2010, 5:06 PM

Post #1 of 4 (1929 views)
Shortcut
1993 Ford F150 "Knock Sensor" Sign In

I recently dropped a 1995 351 Lightening Engine and the old engine was a 302 in my truck and my old engine has a knock sensor and the new eng doesn't have a place for one??? I got the engine running but it has a performance problem??? I'm wondering if this could be the problem, I do not have a check eng light on and it does work??? I have been over every square inch of this engine and can not find a problem with anything else... Can anyone help me out here??? Thank You!!!


(This post was edited by Coolkat on Mar 2, 2010, 5:07 PM)


nickwarner
Veteran / Moderator
nickwarner profile image

Mar 2, 2010, 10:46 PM

Post #2 of 4 (1920 views)
Shortcut
Re: 1993 Ford F150 "Knock Sensor" [In reply to] Sign In

Did you swap the Lightning computer when you did this? 351 had a different firing order than a 302 and if 302 computer is in it this can cause trouble. Its not going to fire injectors in the right order, and will run like crap.


Sidom
Veteran / Moderator
Sidom profile image

Mar 3, 2010, 12:41 AM

Post #3 of 4 (1919 views)
Shortcut
Re: 1993 Ford F150 "Knock Sensor" [In reply to] Sign In

Got go with Nick on this one. If you didn't swap comps then you have more problems then just a missing knock sensor......

A side note the worse problem you would notice with a knock sensor would be a lack of power.






__________________________________________________________________________________________



Coolkat
New User

Mar 3, 2010, 9:49 PM

Post #4 of 4 (1912 views)
Shortcut
Re: 1993 Ford F150 "Knock Sensor" [In reply to] Sign In

Sorry I forgot to tell you I used the cam out of the 302 (it was a high performance cam that had pretty much the same specs as the lightening cam) I knew about the firing order difference and knew this would cause a problem and they didn't have the computer where I got the engine from, so I am using the old 302 firing order... Thank You!!!


(This post was edited by Coolkat on Mar 3, 2010, 10:51 PM)




Advertising


  Email This Post
 
 






Latest Forum Post

hi, my engine still runs after i turn the key off then dies after few seconds, w...


I have a 12v solenoid with the standard two large terminals and it has TWO small...


Hey everyone. I've got my great 84 VW Jetta. It's my first car and while I've ...


Hi Everyone, I have a 2000 Oldsmobile intrigue that when I turn it on the brake ...


I apologize I have not got a lot of time in it so far, so I do not have a lot of...


I have a 1992 ford ranger 3.0l v6 5 speed. today i ran out of gas and when i got...


Feed Button






Automotive Forum Categories
AC Auto Repair
Auto Body Repair
Auto Insurance
Automotive Repair
Automotive Wiring
Automotive World
Brake Systems
Car Care Tips
Car Racing
Car Shows and Events
Car Stereo Repair
Car Troubleshooting
Engine and Car Noises
Engine Fault Codes
Engine Troubleshooting
Exhaust System Repair
Gasoline and Motor Oils
General Discussions
Motor Vehicle Inspection
Motorcycle ATV Repairs
Motorcycle Body Repair
Motorcycle Clutch Repair
Motorcycle Engine Repair
Motorcycle Repair
Motorcycle Seat Repair
Remote Control Cars
Steering and Suspension
The Bargin Bin
Traffic Ticket Help
Tricks of the Trade
Truck Repair
Truck Repair Advice
Truck Engine Repair
Truck Suspension Repair
Car Forum - Sitemap


Search for (options) Privacy