Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN









NO Power 04 GMC 4.3


  Email This Post



Pokerface77
Novice

Jul 19, 2012, 5:50 PM

Post #1 of 4 (954 views)
Shortcut
NO Power 04 GMC 4.3 Sign In

04 GMC Silverado
4-3 v6 182000

Check engine light on. P0430 below threshold bank 2, P0300 Random/Multiple, P0101 MAF/VAF (latest code to show).

Began with just the P0430. Truck was running fine so I just put it in the back of my mind. After about 2 wks, light went out. Now, complete lack of power, 0-60 about 30 sec. If I force it, it sounds very throaty like it's in the intake shorkel. I'm suspecting clogged cat bank 2 with such a loss of power. Idles just fine.

This thing normally has plenty of power. Can easily tow my 24 travel trailer all day long. Help please.


nickwarner
Veteran / Moderator
nickwarner profile image

Jul 19, 2012, 6:14 PM

Post #2 of 4 (944 views)
Shortcut
Re: NO Power 04 GMC 4.3 [In reply to] Sign In

If you don't have a way to test the exhaust backpressure, hook up a vacuum gauge and run at idle. Now rev to 2500-3000rpm. If vacuum drops near zero it almost certainly points to a bad cat.


Pokerface77
Novice

Jul 19, 2012, 10:20 PM

Post #3 of 4 (908 views)
Shortcut
post icon Re: NO Power 04 GMC 4.3 [In reply to] Sign In

Exactly right. I just had to confirm my suspecions before taking the leap. Checked, then drilled a few relief holes through the innerds of the cat. Power is back. Now to get a cat replaced. Thanks for the confirmation.


nickwarner
Veteran / Moderator
nickwarner profile image

Jul 20, 2012, 8:42 PM

Post #4 of 4 (890 views)
Shortcut
Re: NO Power 04 GMC 4.3 [In reply to] Sign In

Thanks for posting the fix and glad you want to diagnose instead of waste money. We're always here for the next repair.




Advertising


  Email This Post
 
 






Latest Forum Post

I have a weird situation in that my run lights won't work on my utility trailer....


A few days ago my driver-side headlight went out, and last night my passenger-si...


I recently blew an engine-'01 CHEV SILVERADO 5.3L-& had an '02 5.3L transpla...


hi, my engine still runs after i turn the key off then dies after few seconds, w...


My 1995 Nissan Quest starts just fine. When I depress the brake pedal and move t...


I have a 1992 ford ranger 3.0l v6 5 speed. today i ran out of gas and when i got...


Feed Button






Automotive Forum Categories
AC Auto Repair
Auto Body Repair
Auto Insurance
Automotive Repair
Automotive Wiring
Automotive World
Brake Systems
Car Care Tips
Car Racing
Car Shows and Events
Car Stereo Repair
Car Troubleshooting
Engine and Car Noises
Engine Fault Codes
Engine Troubleshooting
Exhaust System Repair
Gasoline and Motor Oils
General Discussions
Motor Vehicle Inspection
Motorcycle ATV Repairs
Motorcycle Body Repair
Motorcycle Clutch Repair
Motorcycle Engine Repair
Motorcycle Repair
Motorcycle Seat Repair
Remote Control Cars
Steering and Suspension
The Bargin Bin
Traffic Ticket Help
Tricks of the Trade
Truck Repair
Truck Repair Advice
Truck Engine Repair
Truck Suspension Repair
Car Forum - Sitemap


Search for (options) Privacy