Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN









NO Power 04 GMC 4.3


  Email This Post



Pokerface77
Novice

Jul 19, 2012, 5:50 PM

Post #1 of 4 (1117 views)
Shortcut
NO Power 04 GMC 4.3 Sign In

04 GMC Silverado
4-3 v6 182000

Check engine light on. P0430 below threshold bank 2, P0300 Random/Multiple, P0101 MAF/VAF (latest code to show).

Began with just the P0430. Truck was running fine so I just put it in the back of my mind. After about 2 wks, light went out. Now, complete lack of power, 0-60 about 30 sec. If I force it, it sounds very throaty like it's in the intake shorkel. I'm suspecting clogged cat bank 2 with such a loss of power. Idles just fine.

This thing normally has plenty of power. Can easily tow my 24 travel trailer all day long. Help please.


nickwarner
Veteran / Moderator
nickwarner profile image

Jul 19, 2012, 6:14 PM

Post #2 of 4 (1107 views)
Shortcut
Re: NO Power 04 GMC 4.3 [In reply to] Sign In

If you don't have a way to test the exhaust backpressure, hook up a vacuum gauge and run at idle. Now rev to 2500-3000rpm. If vacuum drops near zero it almost certainly points to a bad cat.


Pokerface77
Novice

Jul 19, 2012, 10:20 PM

Post #3 of 4 (1071 views)
Shortcut
post icon Re: NO Power 04 GMC 4.3 [In reply to] Sign In

Exactly right. I just had to confirm my suspecions before taking the leap. Checked, then drilled a few relief holes through the innerds of the cat. Power is back. Now to get a cat replaced. Thanks for the confirmation.


nickwarner
Veteran / Moderator
nickwarner profile image

Jul 20, 2012, 8:42 PM

Post #4 of 4 (1053 views)
Shortcut
Re: NO Power 04 GMC 4.3 [In reply to] Sign In

Thanks for posting the fix and glad you want to diagnose instead of waste money. We're always here for the next repair.




NO Power 04 GMC 4.3


  Email This Post
 
 






Latest Forum Post

I have a 1974 Chev Nova with a 509/Turbo 400. 90k original mileage. Car is alwa...


Okay guys, this one's been a real pain for me. I've been having trouble with an ...


I am working on a 1989 Jimmy S15. The blinker works ok when you turn left but wh...


i have a 2006 Chrysler pacifica 3.5 liter I recently bought this car with some e...


Having problems with my transmission shifting out of overdrive after driving it ...


I have a 2003 Ford E250 Van, 5.4l engine with 128,000 miles. My key will lock m...


Feed Button






Automotive Forum Categories
AC Auto Repair
Auto Body Repair
Auto Insurance
Automotive Repair
Automotive Wiring
Automotive World
Brake Systems
Car Care Tips
Car Racing
Car Shows and Events
Car Stereo Repair
Car Troubleshooting
Engine and Car Noises
Engine Fault Codes
Engine Troubleshooting
Exhaust System Repair
Gasoline and Motor Oils
General Discussions
Motor Vehicle Inspection
Motorcycle ATV Repairs
Motorcycle Body Repair
Motorcycle Clutch Repair
Motorcycle Engine Repair
Motorcycle Repair
Motorcycle Seat Repair
Remote Control Cars
Steering and Suspension
The Bargin Bin
Traffic Ticket Help
Tricks of the Trade
Truck Repair
Truck Repair Advice
Truck Engine Repair
Truck Suspension Repair
Car Forum - Sitemap


Search for (options) Privacy

web statistics