Main IndexAuto Repair Home Search Posts SEARCH
Who's Online WHO'S
Log in LOG

EVAP problems I think?

  Email This Post

New User

Jan 25, 2012, 12:30 PM

Post #1 of 2 (1231 views)
EVAP problems I think? Sign In

I have a 2000 Blazer that is failing the state inspection. It is giveing 3 coded P0446, P0452, P0453. These seemd to be a evap problem. I called auto zone and they said check the vac tubes on the canister purge valce solenoid and the canister vent valve solenoid. ANy clues where they would be? Any clues what else I can check?
Thanks for the help!

Ultimate Carjunky / Moderator
Discretesignals profile image

Jan 27, 2012, 7:12 PM

Post #2 of 2 (1166 views)
Re: EVAP problems I think? [In reply to] Sign In

You definitely need a high end scan tool to be able to command the vent solenoid to check it's circuit and to see if it is closing when commanded. You also need the scan tool to monitor the fuel tank pressure sensor voltage and pressure PID when the tank is in vacuum.

If you have a wiring schematic, you can check the fuel tank pressure sensor circuit using a volt meter and you may be able to check the vent solenoid by applying external power to it to see if it closes, but that is about the extent. You need to check those things when the system is in purge and seal mode, but you can do that unless you have a scan tool or you manually energize the vent and purge solenoids while watching the FTP sensor voltage.

If you don't have the equipment or the knowledge of checking electrical circuits, your better off taking it to a local repair shop.

Since we volunteer our time and knowledge, we ask for you to please follow up when a problem is resolved.

(This post was edited by Discretesignals on Jan 27, 2012, 7:20 PM)

EVAP problems I think?

  Email This Post

Latest Forum Post

I own a Mitsubishi Eclipse Spyder 2008 and had a brand new battery installed on ...

I have a 86 Ford Bronco with a 302 engine and need a new carb. It is a 2 barrel ...

I have a 1988 Nissan D21 with 124k miles. It's been well taken care of and gener...

car makes a grinding noise when i go in reverse..What could it be?

A?c and heater will not work. The letters "OC" appear on display. What does thi...

I have a '79 Buick with a TH350 non lock-up. It has worked fine after being rebu...

Feed Button

Automotive Forum Categories
AC Auto Repair
Auto Body Repair
Auto Insurance
Automotive Repair
Automotive Wiring
Automotive World
Brake Systems
Car Care Tips
Car Racing
Car Shows and Events
Car Stereo Repair
Car Troubleshooting
Engine and Car Noises
Engine Fault Codes
Engine Troubleshooting
Exhaust System Repair
Gasoline and Motor Oils
General Discussions
Motor Vehicle Inspection
Motorcycle ATV Repairs
Motorcycle Body Repair
Motorcycle Clutch Repair
Motorcycle Engine Repair
Motorcycle Repair
Motorcycle Seat Repair
Remote Control Cars
Steering and Suspension
The Bargin Bin
Traffic Ticket Help
Tricks of the Trade
Truck Repair
Truck Repair Advice
Truck Engine Repair
Truck Suspension Repair
Car Forum - Sitemap

Search for (options) Privacy

web statistics