Main IndexAuto Repair Home Search Posts SEARCH
Who's Online WHO'S
Log in LOG

Code PO 101

  Email This Post

New User

Sep 6, 2009, 9:18 AM

Post #1 of 5 (11035 views)
Code PO 101 Sign In

I put truck on scanner came up with PO 101 Can everyone help me what to do or look for to fix it please

Sierra SLE


Hammer Time
Ultimate Carjunky / Moderator
Hammer Time profile image

Sep 6, 2009, 10:42 AM

Post #2 of 5 (11022 views)
Re: Code PO 101 [In reply to] Sign In

That indicates a problem with the data coming from Mass air flow sensor or it's circuit.


We offer help in answering questions, clarifying things or giving advice but we are not a substitute for an on-site inspection by a professional.

Veteran / Moderator
Sidom profile image

Sep 6, 2009, 10:45 AM

Post #3 of 5 (11016 views)
Re: Code PO 101 [In reply to] Sign In

If you're running a K&N filter, get a can of MAF sensor cleaner & hope you didn't kill you MAF.


New User

Sep 6, 2009, 11:53 AM

Post #4 of 5 (11006 views)
Re: Code PO 101 [In reply to] Sign In

Where can I find it at, (MAF sensor cleaner) call all part store, no luck!!!!

Veteran / Moderator
Sidom profile image

Sep 6, 2009, 12:33 PM

Post #5 of 5 (11000 views)
Re: Code PO 101 [In reply to] Sign In

They may have it & not realize it.

It will be in the carb cleaner, throttle body cleaner section. I believe Gumout (sp) makes it. The one I use is in a gray can. It's designed specifically for MAF sensors, not as harsh as carb clean & does a good job. The main area to clean is the little sensing wire inside the housing

I stand's CRC


(This post was edited by Sidom on Sep 6, 2009, 12:34 PM)

Code PO 101

  Email This Post

Latest Forum Post

I start my car in the morning and it immediately dies. I start it again and befo...

I have a 2002 buick lesabre with a 3.8 auto trans that squeals when turning righ...

Have a 2002 buick lesabre auto tranny with a 3.8 engine that would have heat and...

when I turn the ac on it blows hot air and if I crank it all the way to hi heat ...

Hello everyone here at the forum.Well,my 55 ford 2 door station wagon is still i...

I have a 2010 ford Fiesta 1.4 tdi mk 7 which jumped 3 or 4 teeth on the cambelt....

Feed Button

Automotive Forum Categories
AC Auto Repair
Auto Body Repair
Auto Insurance
Automotive Repair
Automotive Wiring
Automotive World
Brake Systems
Car Care Tips
Car Racing
Car Shows and Events
Car Stereo Repair
Car Troubleshooting
Engine and Car Noises
Engine Fault Codes
Engine Troubleshooting
Exhaust System Repair
Gasoline and Motor Oils
General Discussions
Motor Vehicle Inspection
Motorcycle ATV Repairs
Motorcycle Body Repair
Motorcycle Clutch Repair
Motorcycle Engine Repair
Motorcycle Repair
Motorcycle Seat Repair
Remote Control Cars
Steering and Suspension
The Bargin Bin
Traffic Ticket Help
Tricks of the Trade
Truck Repair
Truck Repair Advice
Truck Engine Repair
Truck Suspension Repair
Car Forum - Sitemap

Search for (options) Privacy

web statistics