Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN









Code PO 101


  Email This Post



whatupjoe
New User

Sep 6, 2009, 9:18 AM

Post #1 of 5 (10268 views)
Shortcut
Code PO 101 Sign In

I put truck on scanner came up with PO 101 Can everyone help me what to do or look for to fix it please
2006
GMC

Sierra SLE
5.3

109,000.


Hammer Time
Ultimate Carjunky / Moderator
Hammer Time profile image

Sep 6, 2009, 10:42 AM

Post #2 of 5 (10255 views)
Shortcut
Re: Code PO 101 [In reply to] Sign In

That indicates a problem with the data coming from Mass air flow sensor or it's circuit.




~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

We offer help in answering questions, clarifying things or giving advice but we are not a substitute for an on-site inspection by a professional.



Sidom
Veteran / Moderator
Sidom profile image

Sep 6, 2009, 10:45 AM

Post #3 of 5 (10249 views)
Shortcut
Re: Code PO 101 [In reply to] Sign In

If you're running a K&N filter, get a can of MAF sensor cleaner & hope you didn't kill you MAF.






__________________________________________________________________________________________



whatupjoe
New User

Sep 6, 2009, 11:53 AM

Post #4 of 5 (10239 views)
Shortcut
Re: Code PO 101 [In reply to] Sign In

Where can I find it at, (MAF sensor cleaner) call all part store, no luck!!!!


Sidom
Veteran / Moderator
Sidom profile image

Sep 6, 2009, 12:33 PM

Post #5 of 5 (10233 views)
Shortcut
Re: Code PO 101 [In reply to] Sign In

They may have it & not realize it.

It will be in the carb cleaner, throttle body cleaner section. I believe Gumout (sp) makes it. The one I use is in a gray can. It's designed specifically for MAF sensors, not as harsh as carb clean & does a good job. The main area to clean is the little sensing wire inside the housing

I stand corrected.....it's CRC







__________________________________________________________________________________________



(This post was edited by Sidom on Sep 6, 2009, 12:34 PM)




Code PO 101


  Email This Post
 
 






Latest Forum Post

1993 Pontiac Grand Am (V6 - 3.3) (300K miles) Hard time starting in cold (winte...


i have a 1998 chevy silverado 5.7 engine over 200,000 miles that won't start tu...


Hi folks, first time joining this board. Looking for help on my 2009 Buick Encl...


So about 3 weeks ago I bought a 2000 ford focus and got the last 3 weeks off dro...


N/A


I bought an 87 GMC 1/2 ton 4x4 with a plow. I brought it home and it started sev...


Feed Button






Automotive Forum Categories
AC Auto Repair
Auto Body Repair
Auto Insurance
Automotive Repair
Automotive Wiring
Automotive World
Brake Systems
Car Care Tips
Car Racing
Car Shows and Events
Car Stereo Repair
Car Troubleshooting
Engine and Car Noises
Engine Fault Codes
Engine Troubleshooting
Exhaust System Repair
Gasoline and Motor Oils
General Discussions
Motor Vehicle Inspection
Motorcycle ATV Repairs
Motorcycle Body Repair
Motorcycle Clutch Repair
Motorcycle Engine Repair
Motorcycle Repair
Motorcycle Seat Repair
Remote Control Cars
Steering and Suspension
The Bargin Bin
Traffic Ticket Help
Tricks of the Trade
Truck Repair
Truck Repair Advice
Truck Engine Repair
Truck Suspension Repair
Car Forum - Sitemap


Search for (options) Privacy

web statistics