Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN









Search Auto Parts

Spark Plug and Ignition Coil problem


  Email This Post



mkstew
New User

Jun 19, 2018, 9:05 AM

Post #1 of 3 (178 views)
Spark Plug and Ignition Coil problem Sign In

have a Lexis IS250, 2009 and 120K miles. Having problem with spark plugs and ignition coils. have had 9 plugs and 7 coils replaced over last 18 months (first change at approx. 100K miles) Each time check engine lights have come on and have experienced loss of power after car has been left outside of garage and unused for 7-14 days. Wondering if some atmospheric or weather/ exposure problem is affecting this? Could it be corrosion/ oxidization or something affecting the plugs, coils or ignition coil wire when the car is left unused for a period of time? have not checked, but will check, if plugs and coils are defective. All thoughts welcome


Hammer Time
Ultimate Carjunky / Moderator
Hammer Time profile image

Jun 19, 2018, 10:02 AM

Post #2 of 3 (172 views)
Re: Spark Plug and Ignition Coil problem Sign In

You should only have to pay for a coil or a spark plug once. The job should be guaranteed for at least a year.



~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

We offer help in answering questions, clarifying things or giving advice but we are not a substitute for an on-site inspection by a professional.



Sidom
Veteran / Moderator
Sidom profile image

Jun 19, 2018, 11:58 AM

Post #3 of 3 (163 views)
Re: Spark Plug and Ignition Coil problem Sign In

Either they are using sub standard parts or something else is going on...

That is way too many parts for that short of period....


(This post was edited by Sidom on Jun 19, 2018, 11:59 AM)






  Email This Post
 
 


Feed Button




Search for (options) Privacy Sitemap