Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN









Neutral Safety Switch


  Email This Post



sherwin1
New User

May 19, 2012, 8:23 AM

Post #1 of 3 (873 views)
Shortcut
Neutral Safety Switch Sign In

Year of vehicle: 2003
Make of vehicle: Ford
Model of vehicle: Mustang
Engine size: 3.7
Mileage: 52000

So I got my car towed last week for having it parked in a parking lot. I go to the place, guy drives it out to me, and I notice that it wasn't in drive, but 2nd gear. Odd, it looked like it was shifted in between the two on the indicator, so i shifted into drive and went home.

I get home, and then try to start my car to go somewhere else later that night when my car doesn't start. Neighbor notices the problem and rather quickly identifies it as a Neutral Safety Switch issue.

My question is, could towing the car have caused this to happen? Thanks.


Hammer Time
Ultimate Carjunky / Moderator
Hammer Time profile image

May 19, 2012, 8:33 AM

Post #2 of 3 (867 views)
Shortcut
Re: Neutral Safety Switch [In reply to] Sign In

Yes, definitely. If the car was in Park and they didn't have a key, they likely went under the car and forced the linkage out of park and likely did some damage.




~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

We offer help in answering questions, clarifying things or giving advice but we are not a substitute for an on-site inspection by a professional.



sherwin1
New User

May 22, 2012, 9:18 PM

Post #3 of 3 (765 views)
Shortcut
Re: Neutral Safety Switch [In reply to] Sign In

Thank you so much! I'll be talking to the tow company.




Neutral Safety Switch


  Email This Post
 
 






Latest Forum Post

i have a suzuki grand vitara 56 plate 1.9 ddis with a renault engine and am wond...


Vehicle: Dodge, Stratus, 4 cylinder, 2002. Immediately after start up as I back ...


Daf cf 430 turning over not starting engine warning light on ,any suggestions?


I got a 1999 Chev pickup. It is thowing a P0441 code. What do I do to check it o...


I own a 2003 Mazda6i 4 speed automatic transmission 2.3 liter engine. 160,000 mi...


I thought I would give this forum a try since I felt I might be able to speak to...


Feed Button






Automotive Forum Categories
AC Auto Repair
Auto Body Repair
Auto Insurance
Automotive Repair
Automotive Wiring
Automotive World
Brake Systems
Car Care Tips
Car Racing
Car Shows and Events
Car Stereo Repair
Car Troubleshooting
Engine and Car Noises
Engine Fault Codes
Engine Troubleshooting
Exhaust System Repair
Gasoline and Motor Oils
General Discussions
Motor Vehicle Inspection
Motorcycle ATV Repairs
Motorcycle Body Repair
Motorcycle Clutch Repair
Motorcycle Engine Repair
Motorcycle Repair
Motorcycle Seat Repair
Remote Control Cars
Steering and Suspension
The Bargin Bin
Traffic Ticket Help
Tricks of the Trade
Truck Repair
Truck Repair Advice
Truck Engine Repair
Truck Suspension Repair
Car Forum - Sitemap


Search for (options) Privacy

web statistics