Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN









Eclipse GS no power


  Email This Post



freakTCHB
New User

Mar 29, 2012, 11:08 PM

Post #1 of 4 (666 views)
Shortcut
Eclipse GS no power Sign In

unsure of year. thinking of buying it if its an easy fix

the guy says the car needs to be jumped, but it turns over easy and starts right up and will run all day. but once the car is shut off, everything is completly dead. no lights no power. nothing. its not the battery or the alternator, he says its a wiring issue. does anyone have any idea what could be wrong with it?


Hammer Time
Ultimate Carjunky / Moderator
Hammer Time profile image

Mar 30, 2012, 6:13 AM

Post #2 of 4 (621 views)
Shortcut
Re: Eclipse GS no power [In reply to] Sign In

If a jump start gets it going and it continues to run, then it is a battery problem or something drawing on the battery overnight.




~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

We offer help in answering questions, clarifying things or giving advice but we are not a substitute for an on-site inspection by a professional.



Discretesignals
Veteran / Moderator
Discretesignals profile image

Mar 30, 2012, 7:50 AM

Post #3 of 4 (615 views)
Shortcut
Re: Eclipse GS no power [In reply to] Sign In

I'm sure there is a lot more wrong with it than just the battery. It may run all day long, but how does it run? Will it even move? How about the brakes. Does it overheat, blow smoke, or make noises? Don't take the sellers word for it, check it out.





Since we volunteer our time and knowledge, we ask for you to please follow up when a problem is resolved.


freakTCHB
New User

Mar 30, 2012, 1:06 PM

Post #4 of 4 (603 views)
Shortcut
Re: Eclipse GS no power [In reply to] Sign In

im deffinatly going to check it out. says its just been sitting other than the starting up so the fuel lines dont get clogged. im thinking the battery is dead or hes got horrible terminals that are corroded. says it runs drives everything just needs jumped. ill definatly check it out tho. in this condition its a steal if everything is good




Advertising


  Email This Post
 
 






Latest Forum Post

hi everyone I was vacuum testing an engine and when I wide open the throttle th...


Hi,here's the info,hope a few members can help me please Car 1998 Olds int...


hey there folks. So i just bought my first car for $600. it was saftied and came...


My question is regarding a problem with an 03 Infiniti G35 with 5 speed automati...


 HotOil warning, from cold start, and won't start, Jeep JK wrangler 2010 un...


 Had starter, alt, battery checked. Car starts great but will go completely...


Feed Button






Automotive Forum Categories
AC Auto Repair
Auto Body Repair
Auto Insurance
Automotive Repair
Automotive Wiring
Automotive World
Brake Systems
Car Care Tips
Car Racing
Car Shows and Events
Car Stereo Repair
Car Troubleshooting
Engine and Car Noises
Engine Fault Codes
Engine Troubleshooting
Exhaust System Repair
Gasoline and Motor Oils
General Discussions
Motor Vehicle Inspection
Motorcycle ATV Repairs
Motorcycle Body Repair
Motorcycle Clutch Repair
Motorcycle Engine Repair
Motorcycle Repair
Motorcycle Seat Repair
Remote Control Cars
Steering and Suspension
The Bargin Bin
Traffic Ticket Help
Tricks of the Trade
Truck Repair
Truck Repair Advice
Truck Engine Repair
Truck Suspension Repair
Car Forum - Sitemap


Search for (options) Privacy