Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN




98' Chevy Camaro Z28 electrical problem?


  Email This Post



tbasilio
New User

Jan 13, 2010, 1:46 PM

Post #1 of 2 (945 views)
Shortcut
98' Chevy Camaro Z28 electrical problem? Sign In

The car goes through 3 basic events, all at random A) Every once in awhile I'll get in the car, turn the key, and there's nothing, no noise, no clicking, no dash lights. I open the hood, play around with the battery connection, jiggle some wires, tap this and that, and after a few attempts it will start. B) I'll be at a stop light idleing and all of a sudden the engine really slows down and then shuts off, again no power. Turn the key to re-start and nothing same as A). I go through my routine and after a few attemtps it starts. C) I'll be driving and all of a sudden the car shuts down, which is pretty dangerous. Same thing as A) and B) go through the routine and the car will start. There is no pattern to when any of these events occurs. I've gone 300 plus miles without incident (over the course of several days) and it will happen after only 10 to 20 miles from the last incident. The battery is fairly new as are the battery cables. The only other thing I've noticed with regards to A) is when I first get in the car sometimes I've noticed the "security light" is on in the dash board. Don't know if this is a constant whenever incidentA) occurs.


Sidom
Veteran / Moderator
Sidom profile image

Jan 14, 2010, 12:32 AM

Post #2 of 2 (934 views)
Shortcut
Re: 98' Chevy Camaro Z28 electrical problem? [In reply to] Sign In

Start out with the basics......... Get the battery test 1st, don't make the mistake of overlooking it because it's new. If it checks out clean the terminals and where the negative cable attaches to the block & body to see if that makes a difference............






__________________________________________________________________________________________





98' Chevy Camaro Z28 electrical problem?


  Email This Post
 
 






Latest Forum Post

2008 E350SD, 5.4 auto 275K. Engine won't crank, no flashing anti-theft. Bypassed...


Hi guys. I have a peugeot 307 hdi 2.0 90. I was driving home the other day and t...


Battery won't stay charged. Autozone tested the battery and alternator and said ...


Hi I have an Audi 1.6 petrol A3 57 plate. I was recently on a long journey when ...


I have a 2002 mazda protege automatic and decided to change the speed sensor mys...


I have a Ford 78 lincoln continental 460 big block. When turning on the headligh...


Feed Button






Automotive Forum Categories
AC Auto Repair
Auto Body Repair
Auto Insurance
Automotive Repair
Automotive Wiring
Automotive World
Brake Systems
Car Care Tips
Car Racing
Car Shows and Events
Car Stereo Repair
Car Troubleshooting
Engine and Car Noises
Engine Fault Codes
Engine Troubleshooting
Exhaust System Repair
Gasoline and Motor Oils
General Discussions
Motor Vehicle Inspection
Motorcycle ATV Repairs
Motorcycle Body Repair
Motorcycle Clutch Repair
Motorcycle Engine Repair
Motorcycle Repair
Motorcycle Seat Repair
Remote Control Cars
Steering and Suspension
The Bargin Bin
Traffic Ticket Help
Tricks of the Trade
Truck Repair
Truck Repair Advice
Truck Engine Repair
Truck Suspension Repair
Car Forum - Sitemap


Search for (options) Privacy

web statistics