Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN









Search Auto Parts

92 Olds achevia crank no start


  Email This Post



KiLLa187
User

Jul 13, 2019, 10:13 AM

Post #1 of 23 (234 views)
92 Olds achevia crank no start Sign In

So I have a 92 Oldsmobile Achieva SL 3.3L V6, that I got about a year ago with only 80k miles on it, when I got it I had to replace the ignition switch cause the kid that had it tore it up and had it rigged to keep the key in... Well a year later after all that I have a crank no start issue, and I noticed my dash lights aren't going on, and it won't go into diagnostic mode(obd1) also it seems the head and brake lights work with but the turn signals don't.. Could a bad ignition switch cause the fuel pump and spark plugs to also not get power, but still engage the starter?


Hammer Time
Ultimate Carjunky / Moderator
Hammer Time profile image

Jul 13, 2019, 11:11 AM

Post #2 of 23 (218 views)
Re: 92 Olds achevia crank no start Sign In

Sure it could but we are talking about the electrical ignition switch, not the ignition lock.

Test all your fuses and fusible links with a test light with the ignition on.



~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

We offer help in answering questions, clarifying things or giving advice but we are not a substitute for an on-site inspection by a professional.



Tom Greenleaf
Ultimate Carjunky / Moderator
Tom Greenleaf profile image

Jul 13, 2019, 11:21 AM

Post #3 of 23 (216 views)
Re: 92 Olds achevia crank no start Sign In

? Whatever mess you are turning isn't reaching the ignition switch - that's just the key. Brake light, headlight would work without a key at all as well as the hazard flashers.
You are looking at the destruction I suppose it can't push/pull rod to the actual ignition for some reason. Try to see the real ignition switch if anything is happening there by turning key or if maybe it just gave up?
If parts in the column are damaged and not just adjusted when inside with steering wheel off takes a tool for that plus if an airbag need to find specifics on dealing with that is unknow for 1992 to me if it has one or not.
Other could be give it a shot at somehow a good whole steering column if any luck same color and feature and has the key would be easier if damage did this. Otherwise check down at the ignition switch should be at or around area over brake pedal remove what's in the way carefully not to bust anything,


T



KiLLa187
User

Jul 13, 2019, 12:21 PM

Post #4 of 23 (207 views)
Re: 92 Olds achevia crank no start Sign In

I know how it works.. I already have the ignition switch out which BTW is super simple on this car, just remove the plastic cover and take out two torx bolts.. With the switch out and using a screwdriver if I turn it to the on position it doesn't light the dash, radio powers and the vent fans will turn on, and it will crank over, but no fuel pressure no spark and no dash lights, and with a jumper installed no diagnostic mode.


Tom Greenleaf
Ultimate Carjunky / Moderator
Tom Greenleaf profile image

Jul 13, 2019, 12:41 PM

Post #5 of 23 (197 views)
Re: 92 Olds achevia crank no start Sign In

I think I understand you. Right from the switch itself nothing happens? Now time for a test light - plain one should do. See what has power there. Brake lights and headlights don't need the column nor are switched by key. Same for horn and hazards that button on top of column isn't it. If that works there's power getting up to it.
So far everything you mentioned would work without keys at all. Nothing changes so power now isn't likely at the plug to switch. ? Power there should go thru the fuse box certainly check all those.
Other? Since the key cylinder was all messed with anything else down in sight for hacked up wiring for stuff it may not have now? If hacked up a key can't trust same person didn't just chop into wires for something else just looking for power with it running or key on .


Start with that this is pretty basic but hacked up just isn't anything by some book anymore if found try to redo busted wire connections most obvious if tapped into are NOT from GM I fear that now then if nothing on to power making it thru firewall,


Tom



KiLLa187
User

Jul 13, 2019, 1:04 PM

Post #6 of 23 (190 views)
Re: 92 Olds achevia crank no start Sign In

The stereo and the vent blower motors are controlled by the ignition switch tho... I bought a new switch, I'll let you know if it's the culprit.


Hammer Time
Ultimate Carjunky / Moderator
Hammer Time profile image

Jul 13, 2019, 1:05 PM

Post #7 of 23 (188 views)
Re: 92 Olds achevia crank no start Sign In

Did you test the fuses and fusible link like I advised before you start throwing parts at it?



~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

We offer help in answering questions, clarifying things or giving advice but we are not a substitute for an on-site inspection by a professional.



KiLLa187
User

Jul 13, 2019, 4:09 PM

Post #8 of 23 (180 views)
Re: 92 Olds achevia crank no start Sign In

Ignition switch replacement was indeed the issue with getting power to multiple things, problem now is the fuel pump is receiving no power and the fuel gauge is showing like there's not one at all. Brand new fuel pump(20+ year old car needed replaced anyways) No fuses blown, have swapped relays and nothing changes.. Haven't tried testing the relay and fuse terminals cause I don't have test light or a car to get one..


KiLLa187
User

Jul 13, 2019, 4:11 PM

Post #9 of 23 (175 views)
Re: 92 Olds achevia crank no start Sign In

And did I mention the car ran solid for about a year and a half before this?


Hammer Time
Ultimate Carjunky / Moderator
Hammer Time profile image

Jul 13, 2019, 4:12 PM

Post #10 of 23 (175 views)
Re: 92 Olds achevia crank no start Sign In


Quote
Haven't tried testing the relay and fuse terminals cause I don't have test light or a car to get one..


Then how do you know the fuel pump isn't getting any power?



~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

We offer help in answering questions, clarifying things or giving advice but we are not a substitute for an on-site inspection by a professional.



KiLLa187
User

Jul 13, 2019, 5:48 PM

Post #11 of 23 (171 views)
Re: 92 Olds achevia crank no start Sign In

Well I assume it's not because the fuel level isn't reading.. Is it normal for the wiring harness to differ from the original? It looks like the new pumps ground pin isn't connected to a pin on the female connector..




(This post was edited by KiLLa187 on Jul 13, 2019, 6:10 PM)


Hammer Time
Ultimate Carjunky / Moderator
Hammer Time profile image

Jul 13, 2019, 5:53 PM

Post #12 of 23 (164 views)
Re: 92 Olds achevia crank no start Sign In

That's an assumption you never want to make. Those are 2 entirely different circuits.

When did you change this pump? Hasn't it been running prior to this?



~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

We offer help in answering questions, clarifying things or giving advice but we are not a substitute for an on-site inspection by a professional.



Tom Greenleaf
Ultimate Carjunky / Moderator
Tom Greenleaf profile image

Jul 13, 2019, 6:40 PM

Post #13 of 23 (157 views)
Re: 92 Olds achevia crank no start Sign In

KiLLa187 : Time to get a silly test light or IDK how you are checking anything. DVOM or an analog one can be had cheap. Ordinary outlets on line even Harbor Freight, Walmart even. All the items you are seeing that don't work have zero power as if key isn't turned at all to even "run" position key or not.
Hammer mentioned the under the hood fusible links. Without those tools you really can't even test a fuse just looking at them isn't enough.
There's no point in much without having those to test things. No ride or transportation to have one 7 days a week can't be helping. If stuck enough to get tools to even check maybe time to tow it a place this should be just primal testing where power is lost IMO.
If this is your only vehicle to get anywhere or do something for just testing tools figure that out. Anything can quit without warning new or this. I can't fix that you should have some alternative just anyway isn't our problem - places deliver or next day pay extra all over maybe $30 bucks worth of testing tools for now delivery will cost more,


Tom



Hammer Time
Ultimate Carjunky / Moderator
Hammer Time profile image

Jul 13, 2019, 6:44 PM

Post #14 of 23 (155 views)
Re: 92 Olds achevia crank no start Sign In

Now that I've seen those pictures, you definitely have the wrong fuel pump there.



~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

We offer help in answering questions, clarifying things or giving advice but we are not a substitute for an on-site inspection by a professional.



KiLLa187
User

Jul 13, 2019, 10:51 PM

Post #15 of 23 (144 views)
Re: 92 Olds achevia crank no start Sign In

I'm testing it by process of elimination and logic.. Ignition switch was the problem originally, I put in the wrong fuel pump because I should have looked closely at the connectors, put the old pump back in, fires right up but still has a slight fuel starvation from the old pump, so once I get that Actual fuel pump to replace the old one, it'll be good as new. Yay it runs! @@


Hammer Time
Ultimate Carjunky / Moderator
Hammer Time profile image

Jul 14, 2019, 4:04 AM

Post #16 of 23 (130 views)
Re: 92 Olds achevia crank no start Sign In

That's good.

In the meantime go into your image and reduce the size by at least 50% so I won't have to delete it. It is way too large and making the thread hard to read.
The image hosting software makes that very easy to do.

Just click on this icon






~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

We offer help in answering questions, clarifying things or giving advice but we are not a substitute for an on-site inspection by a professional.



KiLLa187
User

Jul 19, 2019, 3:32 PM

Post #17 of 23 (104 views)
Re: 92 Olds achevia crank no start Sign In


In Reply To
Now that I've seen those pictures, you definitely have the wrong fuel pump there.

I've purchased a different pump from an entirely different vendor and it has the same wiring harness. 3 wires 3 pins on top.. Wtf do I do now?


Hammer Time
Ultimate Carjunky / Moderator
Hammer Time profile image

Jul 19, 2019, 3:45 PM

Post #18 of 23 (92 views)
Re: 92 Olds achevia crank no start Sign In

I looked it up and every pump I saw has 4 wires so somebody has some bad info. Maybe wrong vehicle or something but something is definitely wrong with those parts.
Most of the better ones even come with a new plug design because of a known issue with the old style.






~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

We offer help in answering questions, clarifying things or giving advice but we are not a substitute for an on-site inspection by a professional.



(This post was edited by Hammer Time on Jul 19, 2019, 3:46 PM)


KiLLa187
User

Jul 19, 2019, 4:48 PM

Post #19 of 23 (86 views)
Re: 92 Olds achevia crank no start Sign In

First one I purchased was a Spectra Premium SP6214M Fuel Pump...second one was a Delphi FG0138 Fuel Pump Module, which even pictures a four wire config. So I don't understand how I got the same exact wiring harness for both pumps. First one I bought doesn't have a forth pin on the assembly but the new one does just doesn't have a wire assigned to it..


Hammer Time
Ultimate Carjunky / Moderator
Hammer Time profile image

Jul 19, 2019, 4:51 PM

Post #20 of 23 (82 views)
Re: 92 Olds achevia crank no start Sign In

It's possible they could have consolidated the 2 grounds into one. You would have to do some testing to determine that.

Were there any instructions included with the pump?



~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

We offer help in answering questions, clarifying things or giving advice but we are not a substitute for an on-site inspection by a professional.



(This post was edited by Hammer Time on Jul 19, 2019, 4:52 PM)


KiLLa187
User

Jul 19, 2019, 5:02 PM

Post #21 of 23 (76 views)
Re: 92 Olds achevia crank no start Sign In

No instructions, and that would make sense IF the ground plug was in the right spot..there is no pin on the male connector(on the car) on top for the ground.. There is only 2 pins on top and 2 grounds on bottom.. Am I going to have to either ground it somewhere, or rewire the old connector to the new assembly?
Also why are there four pins on the new assembly?


(This post was edited by KiLLa187 on Jul 19, 2019, 5:06 PM)


Hammer Time
Ultimate Carjunky / Moderator
Hammer Time profile image

Jul 19, 2019, 5:16 PM

Post #22 of 23 (61 views)
Re: 92 Olds achevia crank no start Sign In

No, you just need to get the right pump if there are no modification instructions with the unit.

The wiring diagram shows a 4 wire system.



~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

We offer help in answering questions, clarifying things or giving advice but we are not a substitute for an on-site inspection by a professional.



KiLLa187
User

Jul 19, 2019, 5:31 PM

Post #23 of 23 (57 views)
Re: 92 Olds achevia crank no start Sign In

That doesn't explain why it would have 4 pins on the assembly and 3 wires coming out.. And you make that sound so easy. It's not so stop trying to get me to buy a third pump.. I asked questions about the pump. Not how to buy another one, I already have displayed that skill. Did you even look at the Delphi? Cause there's no reason it shouldn't work or why it came with clearly the wrong harness.






  Email This Post
 
 


Feed Button




Search for (options) Privacy Sitemap