Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN




2001 Dodge Ram electrcial smell in air system


  Email This Post



flydave
New User

May 4, 2011, 11:12 AM

Post #1 of 2 (1070 views)
Shortcut
2001 Dodge Ram electrcial smell in air system Sign In

I have a Doge Ram 2001 V8 1500 5.8 engine with 145,000 miles

2001 engine smell when the truck warms up on both Defrost and foot blower. DEC 2010 my A/C compressor died and it was replaced with a new one for this truck. I started noticing a smell like electrical or engine (burning something) when defrost was on and also when it was not on. Stronger smell when defrost is on and when it warm up there is no smell when cold. I have notices that the anti-freeze is no but no sign of a leak at all. I was thinking maybe a small leak vapor leak would create the smell. Please help since I need to drive this truck and find a solution.

I have taken it back to the shop but they cannot find anything wrong (of course). This is not the primary car and does sit for a week before we need to drive it.

I have had to cleaned the inside of the windows more often then in previous years. A film has developed inside the wind shield.


Hammer Time
Ultimate Carjunky / Moderator
Hammer Time profile image

May 4, 2011, 11:45 AM

Post #2 of 2 (1066 views)
Shortcut
Re: 2001 Dodge Ram electrcial smell in air system [In reply to] Sign In

You could have a small leak in the heater core. You should have the system pressure tested.




~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

We offer help in answering questions, clarifying things or giving advice but we are not a substitute for an on-site inspection by a professional.





2001 Dodge Ram electrcial smell in air system


  Email This Post
 
 






Latest Forum Post

I have an 89' chev. suburban 4x4 that the upper gears is out. I also have a 90'c...


Hi Everyone, Last night I left my truck (02 Ford Ranger 3.0L) parked in 4WD af...


Hi folks, first time joining this board. Looking for help on my 2009 Buick Encl...


I am having a problem with my wife's Ford 2003 Escape. I went down to get the c...


gearheads.....the car is a toyota 22re......i gave it a try to look down the the...


My 96 Camry SV40 has an amron battery just 2 years old. Now it sometimes does no...


Feed Button






Automotive Forum Categories
AC Auto Repair
Auto Body Repair
Auto Insurance
Automotive Repair
Automotive Wiring
Automotive World
Brake Systems
Car Care Tips
Car Racing
Car Shows and Events
Car Stereo Repair
Car Troubleshooting
Engine and Car Noises
Engine Fault Codes
Engine Troubleshooting
Exhaust System Repair
Gasoline and Motor Oils
General Discussions
Motor Vehicle Inspection
Motorcycle ATV Repairs
Motorcycle Body Repair
Motorcycle Clutch Repair
Motorcycle Engine Repair
Motorcycle Repair
Motorcycle Seat Repair
Remote Control Cars
Steering and Suspension
The Bargin Bin
Traffic Ticket Help
Tricks of the Trade
Truck Repair
Truck Repair Advice
Truck Engine Repair
Truck Suspension Repair
Car Forum - Sitemap


Search for (options) Privacy

web statistics