Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN









2000 dodge stratus no power to powerwindows


  Email This Post



cgreer45
New User

Jan 17, 2010, 12:17 PM

Post #1 of 4 (1394 views)
Shortcut
2000 dodge stratus no power to powerwindows Sign In

Just bought this car at an auction,2000 dodge stratus se 135000 miles 2.4L. power windows and mirrors don't work have no power to that fuse! also keeps blowing interior fuse as soon as it is inserted! and the blower only works on high, can you give me some advise on what to do?


Sidom
Veteran / Moderator
Sidom profile image

Jan 17, 2010, 2:27 PM

Post #2 of 4 (1385 views)
Shortcut
Re: 2000 dodge stratus no power to powerwindows [In reply to] Sign In

I'm not sure of your electrical abilities but with these problems it might not be a bad idea to get a good manual with some good wiring diagrams to help you track down these electrical problems sounds like there is a couple going on right now..

You might start with the dead fuse #1. You are going to have to track down the wire that feeds that fuse in the box & repair the circuit or replace the box, whatever the problem is and then see if that fix had any effect on the other problems and go from there.........






__________________________________________________________________________________________



bobbaganush
New User

Oct 29, 2011, 8:43 PM

Post #3 of 4 (1135 views)
Shortcut
Re: 2000 dodge stratus no power to powerwindows [In reply to] Sign In

for the blower only working on high, put a new blower motor resistor in. it a 30 dollar part from napa and it very easy to install it. its below the glove box.


Tom Greenleaf
Ultimate Carjunky / Moderator
Tom Greenleaf profile image

Oct 31, 2011, 11:00 AM

Post #4 of 4 (1125 views)
Shortcut
Re: 2000 dodge stratus no power to powerwindows [In reply to] Sign In

Please look at dates. This is an old thread now,

T
_________________________________________
Long retired now




Advertising


  Email This Post
 
 






Latest Forum Post

I have a 12v solenoid with the standard two large terminals and it has TWO small...


I apologize I have not got a lot of time in it so far, so I do not have a lot of...


I have a 1992 ford ranger 3.0l v6 5 speed. today i ran out of gas and when i got...


Hey people, Just as soon as I've got rid of one car and got another, I've got a...


Hello I have a 1993 Toyota Corolla w/1.8L and 3 sp +overdrive tranny. I took it ...


2008 Nissan Sentra 2.0 50000 Miles The trunk wouldn't open neither with the rem...


Feed Button






Automotive Forum Categories
AC Auto Repair
Auto Body Repair
Auto Insurance
Automotive Repair
Automotive Wiring
Automotive World
Brake Systems
Car Care Tips
Car Racing
Car Shows and Events
Car Stereo Repair
Car Troubleshooting
Engine and Car Noises
Engine Fault Codes
Engine Troubleshooting
Exhaust System Repair
Gasoline and Motor Oils
General Discussions
Motor Vehicle Inspection
Motorcycle ATV Repairs
Motorcycle Body Repair
Motorcycle Clutch Repair
Motorcycle Engine Repair
Motorcycle Repair
Motorcycle Seat Repair
Remote Control Cars
Steering and Suspension
The Bargin Bin
Traffic Ticket Help
Tricks of the Trade
Truck Repair
Truck Repair Advice
Truck Engine Repair
Truck Suspension Repair
Car Forum - Sitemap


Search for (options) Privacy