Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN









2000 dodge stratus no power to powerwindows


  Email This Post



cgreer45
New User

Jan 17, 2010, 12:17 PM

Post #1 of 4 (1482 views)
Shortcut
2000 dodge stratus no power to powerwindows Sign In

Just bought this car at an auction,2000 dodge stratus se 135000 miles 2.4L. power windows and mirrors don't work have no power to that fuse! also keeps blowing interior fuse as soon as it is inserted! and the blower only works on high, can you give me some advise on what to do?


Sidom
Veteran / Moderator
Sidom profile image

Jan 17, 2010, 2:27 PM

Post #2 of 4 (1473 views)
Shortcut
Re: 2000 dodge stratus no power to powerwindows [In reply to] Sign In

I'm not sure of your electrical abilities but with these problems it might not be a bad idea to get a good manual with some good wiring diagrams to help you track down these electrical problems sounds like there is a couple going on right now..

You might start with the dead fuse #1. You are going to have to track down the wire that feeds that fuse in the box & repair the circuit or replace the box, whatever the problem is and then see if that fix had any effect on the other problems and go from there.........






__________________________________________________________________________________________



bobbaganush
New User

Oct 29, 2011, 8:43 PM

Post #3 of 4 (1223 views)
Shortcut
Re: 2000 dodge stratus no power to powerwindows [In reply to] Sign In

for the blower only working on high, put a new blower motor resistor in. it a 30 dollar part from napa and it very easy to install it. its below the glove box.


Tom Greenleaf
Ultimate Carjunky / Moderator
Tom Greenleaf profile image

Oct 31, 2011, 11:00 AM

Post #4 of 4 (1213 views)
Shortcut
Re: 2000 dodge stratus no power to powerwindows [In reply to] Sign In

Please look at dates. This is an old thread now,

T
_________________________________________
Long retired now




2000 dodge stratus no power to powerwindows


  Email This Post
 
 






Latest Forum Post

Replaced head gaskets in Toyota 4 Runner 3 liter V6. Gaskets had blown. Had he...


Hoping someone can answer a question for me. I have a 2009 Hyundai Sonata with ...


Hey all I have a Ford Chateau 351win 5.8L v8. It has a vanguard motor home body...


I hooked up a new 200amp alternator, in my 2004 eldorado bus. Big ass diesel ,co...


I just inherited a 1989 Siverado with a 454 and dual tanks. It seldom starts on ...


I have a 1995 Ford Ranger, with a 4.0L v6 engine. So basically what happened was...


Feed Button






Automotive Forum Categories
AC Auto Repair
Auto Body Repair
Auto Insurance
Automotive Repair
Automotive Wiring
Automotive World
Brake Systems
Car Care Tips
Car Racing
Car Shows and Events
Car Stereo Repair
Car Troubleshooting
Engine and Car Noises
Engine Fault Codes
Engine Troubleshooting
Exhaust System Repair
Gasoline and Motor Oils
General Discussions
Motor Vehicle Inspection
Motorcycle ATV Repairs
Motorcycle Body Repair
Motorcycle Clutch Repair
Motorcycle Engine Repair
Motorcycle Repair
Motorcycle Seat Repair
Remote Control Cars
Steering and Suspension
The Bargin Bin
Traffic Ticket Help
Tricks of the Trade
Truck Repair
Truck Repair Advice
Truck Engine Repair
Truck Suspension Repair
Car Forum - Sitemap


Search for (options) Privacy

web statistics