Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN




Search Auto Parts

1996 Toyota Tacoma Won't Start


  Email This Post



Military17
New User

Apr 16, 2017, 7:06 AM

Post #1 of 2 (46 views)
1996 Toyota Tacoma Won't Start Sign In

Just got back from a 6 month deployment and my truck won't start. Battery was dead. No power to anything in vehicle-no lights or sounds. Replaced with new battery. Took plastic caps off of posts on new battety. No sounds no lights no power on new battery. Tried charging the new battery over night, still not working. What should I try next? Thank you.


(This post was edited by Military17 on Apr 16, 2017, 7:07 AM)


Tom Greenleaf
Ultimate Carjunky / Moderator
Tom Greenleaf profile image

Apr 16, 2017, 7:27 AM

Post #2 of 2 (35 views)
Re: 1996 Toyota Tacoma Won't Start Sign In

Whatever you have for a charger or test tools you just know there's zero power from this battery new or not it should be charged FIRST then installed with a charger that only minimally tells you it's done what it could.


Now since it's unlikely but not impossible for new one to be just "dead" it's more likely your u-bolt connections are at fault. They might even look OK and tighten up but both must be clean, corrosion free and tight up such that you can't turn them. Toyota and others there more right there as well - all must be clean and tight. Use a protectant grease once all is perfect and they last.


BTW - a battery will not just sit well out of car even for 7 months. If any warning of a "deployment" for long term try to put in on an automatic trickle charger, stabilizer in fuel or best have someone use it now and then if practical?


T
(edit) Your user name is a giveaway that your deployment is military. THANK YOU MY FRIEND! BLESS YOU!!!!



(This post was edited by Tom Greenleaf on Apr 16, 2017, 7:28 AM)






  Email This Post
 
 


Feed Button




Search for (options) Privacy Sitemap

shopify
site analytics