Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN









Search Auto Parts

1996 Mercury Grand Marquis radio not working. (showing some sings of life)


  Email This Post



JDA
New User

Aug 28, 2011, 7:46 PM

Post #1 of 3 (3546 views)
1996 Mercury Grand Marquis radio not working. (showing some sings of life) Sign In

I have a 1996 Mercury Grand Marquis that was given to me and apparently its radios hasnt been working for a few years. The radio buttons iluminate but when I push the on button it doenst turn on.

I think it is showing some sings of lives because when I push some buttons (one of the preset numbers for ex) the screen barely iluminates and goes back to black in a second. What should I check?


zmame
Veteran / Moderator
zmame profile image

Aug 29, 2011, 11:18 AM

Post #2 of 3 (3513 views)
Re: 1996 Mercury Grand Marquis radio not working. (showing some sings of life) Sign In

Pull the radio out. You will need a multi-meter and a 12v bulb to load test.

pull the connector(s) off the back of the radio with your volt meter set to 20VDC put positive probe on the LG/V wire and negitive probe on BK/LG then move negeitive prove to BK wire. They should read battery Voltage. (aprox 12v)

Now turn the key on with the negitive probe still on BK wire move the positive probe to Y/BK wire. Should also have battery voltage with key on.

Now with you 12v bulb connect it between Y/BK and BK and it should light up.
Now Connect 12v bulb between LG/V and BK/LG and should light up.

All the bulb is for is to make sure the circuit can handle a load.

If that all passes then you need a new radio




Discretesignals
Ultimate Carjunky / Moderator
Discretesignals profile image

Aug 29, 2011, 5:33 PM

Post #3 of 3 (3506 views)
Re: 1996 Mercury Grand Marquis radio not working. (showing some sings of life) Sign In

Beautiful reply Zmame Wink


You'll need these to remove the radio:







Since we volunteer our time and knowledge, we ask for you to please follow up when a problem is resolved.






  Email This Post
 
 


Feed Button




Search for (options) Privacy Sitemap