Main IndexAuto Repair Home Search Posts SEARCH
Who's Online WHO'S
Log in LOG

1993 Delco Radio won't work

  Email This Post

New User

Jun 3, 2011, 10:47 PM

Post #1 of 2 (2953 views)
1993 Delco Radio won't work Sign In

I recently inherited a 1993 Chevrolet C/K 5.0L with 260,000+ miles from my grandfather. This isn't my first time with the truck, but the radio doesn't seem to work. I remember I borrowed it in 2006 and the radio was still functional, but now it won't even turn on. I've already replaced the fuse and that wasn't the problem. LOC or ERROR don't display on the screen either. What I've noticed is that when RCL is pressed, the clock displays 1:00 for about 5-7 seconds and then turns off. SET is also able to display, but it doesn't seem to do anything. I'll take it into a shop as a last resort, but I really want to fix it myself. If anybody has any information on this, please respond. I'm desperate to find out what the problem is.


Jun 8, 2011, 12:10 PM

Post #2 of 2 (2897 views)
Re: 1993 Delco Radio won't work [In reply to] Sign In

What does the on/off switch look like? Is it a small button close to the cassette, or is it a knob? Some Delco radios in that era were notorious for having a bad on/off switch. If it is a small (usually red or orange) button, it may be a bad switch. If it is a bad switch, you can bypass the on/off switch by joining the two leads going to the switch together. You won't be able to turn the radio off when the key is on, but everything else should work. The radio will still turn off when the key is off.

1993 Delco Radio won't work

  Email This Post

Latest Forum Post

I have a 1995 Dodge Ram 2500 with the optional trailer towing package. I'm in th...

Newbie to forum and need some help. I have a 2005 Chevy 2500 HD diesel and the p...

My 2004 Dodge Ram 5.7 Hemi originally had two broken bolts on the exhaust manifo...

1999 Subaru Legacy AWD manual 2.2 150,000 miles I had to hit the brakes hard du...

I have a 2003 Jeep Liberty a when I applying the brakes with a the engine revvin...

found the problem, it was the ground wire at the right front corner where the ho...

Feed Button

Automotive Forum Categories
AC Auto Repair
Auto Body Repair
Auto Insurance
Automotive Repair
Automotive Wiring
Automotive World
Brake Systems
Car Care Tips
Car Racing
Car Shows and Events
Car Stereo Repair
Car Troubleshooting
Engine and Car Noises
Engine Fault Codes
Engine Troubleshooting
Exhaust System Repair
Gasoline and Motor Oils
General Discussions
Motor Vehicle Inspection
Motorcycle ATV Repairs
Motorcycle Body Repair
Motorcycle Clutch Repair
Motorcycle Engine Repair
Motorcycle Repair
Motorcycle Seat Repair
Remote Control Cars
Steering and Suspension
The Bargin Bin
Traffic Ticket Help
Tricks of the Trade
Truck Repair
Truck Repair Advice
Truck Engine Repair
Truck Suspension Repair
Car Forum - Sitemap

Search for (options) Privacy

web statistics