Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN









Search Auto Parts

2008 Jeep Liberty weird noise on startup (video)


  Email This Post



dcmartin25
New User

Jun 22, 2016, 3:40 PM

Post #1 of 8 (537 views)
  post locked   2008 Jeep Liberty weird noise on startup (video)  

Ok, to start off it's a 2008 Jeep Liberty, 3.7L engine, around 74k miles on it.
I just bought it back in October with around 67-68k miles on it.

Here's as much backstory on how this started as I can figure out

A couple days ago it was ridiculously hot so I started using the AC for the first time since I owned it. It worked just fine for a 30 mile drive to my parents house for the day. On the way home, however, I noticed the AC wouldn't work at all. Yesterday on the way to the store, no AC again, no matter what I tried. Then when I was leaving the store this noise started. It's continued every time I start the car cold and pretty much lasts until I put it in gear and start driving (but even then I can kind of hear it with the windows down and if I'm near something to bounce the sound back). It sounds to me like something going on with a belt but I'm not completely sure. Could it be related to the AC issue??? Rather than even attempt to describe the sound, I just shot a video of it.

I'll try and embed but if that doesn't work, here's the link: (https://youtu.be/Iu5745GQnJQ)

Any help would be greatly appreciated. If this is something I can fix myself, even better. I just know i need to address this because I have a 2.5 hour drive to a concert (and 2.5 back!) in Cleveland coming up in less than a month and don't like the idea of my car blowing up on me on the way there. Thanks in advance.

(couldn't get the embed to work, link it is)

Edit: should also note... engine temperature has been running just fine. All fluid levels seemed okay. There have been no warning lights on the instrument cluster.


(This post was edited by dcmartin25 on Jun 22, 2016, 3:43 PM)


Hammer Time
Ultimate Carjunky / Moderator
Hammer Time profile image

Jun 22, 2016, 3:58 PM

Post #2 of 8 (529 views)
  post locked   Re: 2008 Jeep Liberty weird noise on startup (video)  

That noise seems to be coming from one of the belt driven components. You may have to remove the belt and move the pulleys by hand to feel for one that isn't smooth. It could be the compressor, the water pump, alternator or any of the idler pulleys.

I wouldn't be driving it around like that though.



~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

We offer help in answering questions, clarifying things or giving advice but we are not a substitute for an on-site inspection by a professional.



(This post was edited by Hammer Time on Jun 22, 2016, 3:59 PM)


dcmartin25
New User

Jun 22, 2016, 4:35 PM

Post #3 of 8 (523 views)
  post locked   Re: 2008 Jeep Liberty weird noise on startup (video)  

Thanks for the tip. Took the belt off and the first pulley I checked seems like the bearings have completely gone out in it. Going to look into replacing that right now. Fortunately, the rest of them seem fine


Hammer Time
Ultimate Carjunky / Moderator
Hammer Time profile image

Jun 22, 2016, 4:38 PM

Post #4 of 8 (520 views)
  post locked   Re: 2008 Jeep Liberty weird noise on startup (video)  

Was it just an idler pulley?



~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

We offer help in answering questions, clarifying things or giving advice but we are not a substitute for an on-site inspection by a professional.



dcmartin25
New User

Jun 22, 2016, 4:52 PM

Post #5 of 8 (518 views)
  post locked   Re: 2008 Jeep Liberty weird noise on startup (video)  

Nope. Sadly it was the a/c compressor pulley. I can honestly live without AC considering a replacement is around $300 but everyone I've checked online around here so far doesn't have the AC bypass pulley available so I may have to man up and replace the whole unit :(


Hammer Time
Ultimate Carjunky / Moderator
Hammer Time profile image

Jun 22, 2016, 5:10 PM

Post #6 of 8 (513 views)
  post locked   Re: 2008 Jeep Liberty weird noise on startup (video)  

If all you have is a bad pulley bearing, you are getting away cheap. If that was internal damage, you would be looking at a lot more damage.



~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

We offer help in answering questions, clarifying things or giving advice but we are not a substitute for an on-site inspection by a professional.



dcmartin25
New User

Jun 22, 2016, 5:22 PM

Post #7 of 8 (511 views)
  post locked   Re: 2008 Jeep Liberty weird noise on startup (video)  

Oh yeah, I was just hoping it would be an idler pulley or even the alternator pulley though. Significantly cheaper but I'll take it over a dead engine any day


Hammer Time
Ultimate Carjunky / Moderator
Hammer Time profile image

Jun 22, 2016, 5:25 PM

Post #8 of 8 (507 views)
  post locked   Re: 2008 Jeep Liberty weird noise on startup (video)  

OK, I'm going to close this now as solved. You can get it re-opened if you need to. Just message any Mod.



~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

We offer help in answering questions, clarifying things or giving advice but we are not a substitute for an on-site inspection by a professional.







  Email This Post
 
 


Feed Button




Search for (options) Privacy Sitemap

shopify
site analytics