Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN









Search Auto Parts

04 Ford Taurus Running Terrible


  Email This Post



fredster1022
Novice

Oct 29, 2018, 7:41 AM

Post #1 of 13 (271 views)
04 Ford Taurus Running Terrible Sign In

I have a 04 Ford Taurus. For about a year the check engine light was on
giving me a code with my OBD11 tool of P0340. I looked it up online and it
showed that was the camshaft position sensor. I drove it for a year and it
was fine and I never had that replaced. I know that was a terrible idea!

Now the car has began running terrible all of the sudden. I was driving and it
was fine and all of the sudden it began sputtering and vibrating. It is making
a clicking sound but I can't tell where it's coming from.

I hooked the OBD tool back up to the car and the following codes appeared.

P0349
P0171
P0174
PO175
P2196
P2197
P2198

I diconenected the battery and when I rescanned the folloowing codes were
still there.

P0340
P2196

I've been told this could be the MAF sensor causing these issues or the
PCM. It could be a vacuum leak and also could be related to the fuel
injectors. Could it just be the Camshaft Position Sensor? Or are these not
related to the same problem?

Help please. I'm not much of a mechanic. I have used the scan tool before
for some sensors on my truck but it never showed multiple codes.
Thanks!


Hammer Time
Ultimate Carjunky / Moderator
Hammer Time profile image

Oct 29, 2018, 12:37 PM

Post #2 of 13 (255 views)
Re: 04 Ford Taurus Running Terrible Sign In

What is the 8th digit of the VIN#?



~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

We offer help in answering questions, clarifying things or giving advice but we are not a substitute for an on-site inspection by a professional.



fredster1022
Novice

Oct 29, 2018, 3:59 PM

Post #3 of 13 (237 views)
Re: 04 Ford Taurus Running Terrible Sign In

The 8th digit in the vin is a U


Hammer Time
Ultimate Carjunky / Moderator
Hammer Time profile image

Oct 29, 2018, 4:19 PM

Post #4 of 13 (225 views)
Re: 04 Ford Taurus Running Terrible Sign In

You seem to have a bunch of different issues that may or may not be related so you'll have to tackle them one at a time, starting with the cam sensor. This is a common issue on this engine and a real pain in the ass to change.

The cam sensor is in the top of the engine where a distributor normally would be. It has to be installed and timed, just like a distributor would be. There is a special tool for doing that and it's impossible to align without that. There are 2 parts that need to be changed. The sensor itself is a plastic piece on top. The bottom half is called a synchronizer and they go bad along with the sensor.

You may have to remove the upper intake to gain access to the sensor.




https://www.amazon.com/...onizer/dp/B000HTNNX0

Here's what the alignment tool looks like.




It looks like Dorman makes a kit with all 3 things

https://www.amazon.com/...2VMX87M4CDF2EQDCE7Z1



~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

We offer help in answering questions, clarifying things or giving advice but we are not a substitute for an on-site inspection by a professional.



(This post was edited by Hammer Time on Oct 29, 2018, 4:23 PM)


fredster1022
Novice

Oct 29, 2018, 4:33 PM

Post #5 of 13 (212 views)
Re: 04 Ford Taurus Running Terrible Sign In

Thank you. I will try to tackle that process. If that is not the case what are some other things to check afterwards?

I'm just trying to get an idea in case it seems like more than I can handle.

In that case I would need a mechanic. I've seen videos on the cam shaft position sensor removal and it doesn't seem that hard but I'm just looking ahead and what could possibly be next in the event this doesn't fix the issue.

Thanks!


Hammer Time
Ultimate Carjunky / Moderator
Hammer Time profile image

Oct 29, 2018, 4:48 PM

Post #6 of 13 (204 views)
Re: 04 Ford Taurus Running Terrible Sign In

That's not how this process works. You fix the known problem first and then you assess any issues that may remain after that repair. You have both lean codes and rich codes without knowing the actual cause yet. The cam sensor could have a lot to do with that. That remains to be seen.

The actual change of the sensor and synchronizer is easy. It's the timing setup that has to be perfect with no mistakes. You also may have to create clearance to get it all the way out of the hole.



~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

We offer help in answering questions, clarifying things or giving advice but we are not a substitute for an on-site inspection by a professional.



fredster1022
Novice

Oct 30, 2018, 12:46 PM

Post #7 of 13 (180 views)
Re: 04 Ford Taurus Running Terrible Sign In

I put the new camshaft sensor on and the P0340 code has went away. Car is still running terribly.

The check engine light came back on showing a code P2197.

I forgot to mention there has been a oil leak somewhere for awhile. I've been adding about a 1/2 quart per month but I drive the car a lot throughout the month.

There is no antifreeze loss.

But there is water dripping from the tailpipe. Of course it is not up to running temperature.

There is also water dripping from about 16" before the end of the exhaust pipe on the right at the beginning the box looking device on the exhaust pipe. (not sure what that is honestly).

Because of the oil loss I did replace the spark plugs thinking they might have been fouled out. It did not change the way it was running.

Before it began running rough and now there has not been any black smoke out of the exhaust pipe.

Help please!


Hammer Time
Ultimate Carjunky / Moderator
Hammer Time profile image

Oct 30, 2018, 12:54 PM

Post #8 of 13 (174 views)
Re: 04 Ford Taurus Running Terrible Sign In

OK, first off, replacing spark plugs will not resolve oil consumption.

You are getting black smoke which indicates rich fuel mixture. You are also getting a len code from the bank one 0/2 sensor. My guess would be that the excessive oil consumption has fouled out the o/2 sensor causing it to report lean which causes the computer to send more fuel.

If you are actually burning that much oil I would think long and hard about investing too much money into this engine. It is only going to happen again and progressively get worse.



~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

We offer help in answering questions, clarifying things or giving advice but we are not a substitute for an on-site inspection by a professional.



fredster1022
Novice

Oct 30, 2018, 1:07 PM

Post #9 of 13 (168 views)
Re: 04 Ford Taurus Running Terrible Sign In

Okay. I am actually NOT getting any black smoke from the exhaust and I have not been.

I will look around underneath previously I had a drain plug problem which was causing a oil leak perhaps this has occurred again or perhaps it is not the oil drag plug but the threads. But it could be looking somewhere else I do not know.

There is no black smoke however

Could it still be the 02 sensor? I do live on a rough road where I sometimes drag bottom. Perhaps I damaged the 02 sensor. I see that is underneath the car. Is there more than 1 02 sensor. Is it easy to replace?


fredster1022
Novice

Oct 30, 2018, 1:11 PM

Post #10 of 13 (162 views)
Re: 04 Ford Taurus Running Terrible Sign In

Could it be a vacuum leak?


Hammer Time
Ultimate Carjunky / Moderator
Hammer Time profile image

Oct 30, 2018, 1:13 PM

Post #11 of 13 (160 views)
Re: 04 Ford Taurus Running Terrible Sign In

Sorry, I read that wrong.

The lean code could be a false reading from a bad sensor or it could actually be running lean. There are ways to test the sensor but it involves monitoring voltages while artificially enriching the engine.

Check it very carefully for any vacuum leaks or air leaks in the intake snorkel.



~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

We offer help in answering questions, clarifying things or giving advice but we are not a substitute for an on-site inspection by a professional.



fredster1022
Novice

Oct 30, 2018, 1:16 PM

Post #12 of 13 (156 views)
Re: 04 Ford Taurus Running Terrible Sign In

What are some ways to check for a vacuum leak.

What is the intake snorkel?

I have a parts car so I can swap out the 02 sensor if you think that might be the culprit.


Hammer Time
Ultimate Carjunky / Moderator
Hammer Time profile image

Oct 30, 2018, 1:27 PM

Post #13 of 13 (140 views)
Re: 04 Ford Taurus Running Terrible Sign In

I don't recommend a used 0/2 sensor. You have no way on knowing if it is any better than the one you have.

There are a few ways to look for a vacuum leak

You can just listen very closely for a hissing noise and find it's origin.
You can use carb cleaner and listen for an engine change when you spray it on a leak
but the only reliable way is to have it smoke tested.

The intake snorkel is the hose from the air cleaner to the throttle body.



~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

We offer help in answering questions, clarifying things or giving advice but we are not a substitute for an on-site inspection by a professional.







  Email This Post
 
 


Feed Button




Search for (options) Privacy Sitemap